Home FlytBase Forums API Reference

Prerequisites

Linux

Visit the Docker installation guide and make sure your flavour of Linux is supported by Docker. If you are running anything apart from Ubuntu, please follow the above guide and install docker in your machine. For Ubuntu users, we have an installation script, details of which are in setup section. It is preferable if you use Ubuntu 14.04 or above.

Windows

Visit installation guide for Docker-for-Windows and install it if it is supported by your Windows OS. Typically 64bit Windows 10 Pro, Enterprise and Education support the newer Docker-for-Windows. To know more about it, click here. Currently we DO NOT support Docker Toolbox (legacy) and have no plan to do it in near future.

MacOS

Visit installation guide for Docker-for-Mac and install it if it is supported by your Mac OS. Typically OS X El Capitan 10.11 and newer macOS releases support the newer Docker-for-Mac. To know more about it, click here. Currently we DO NOT support Docker Toolbox (legacy) and have no plan to do it in near future.

Warning

In MacOS we could not enable GUI support from within Docker, which means if you are keen on having 3D GUI Gazebo based environment, then please use Linux or Windows.